The WiFi Blog

Installing Muft WiFi Management Software on Your Own Router!

With this guide you can learn how to configure your own router to use Muft WiFi Management software. Please note that our software is in beta mode and we aren’t quite ready to offer technical support for free plan users. We are continuously working on ways to improve this platform. In future, we plan to add a lot more free and premium features.

Create a network of guest/public hotspots with Muft (free) WiFi Management software. This is an online cloud based software ideal for small and medium businesses to manage their WiFi Advertising, WiFi Monetization & WiFi Security. Before you use start your WiFi business with this software – you need 2 things:

Step 1: Create a Muft WiFi Management Software Account:

Create an account on Muft WiFi if you haven’t already! It’s free! Click here to sign up

Step 2: A router configured with Muft WiFi’s settings

Muft WiFi Management Software is compatible with most Mikrotik OS Routers & dd-wrt compatible routers. Configure your own router using the guide below.

In the following sections we discuss specific installation procedures for 1. DD-WRT and then 2. Microtik.


1. For DD-WRT USERS

STEP 1: IS MY ROUTER DD-WRT COMPATIBLE?

To check if you have a DD-WRT supported router you can follow this link: https://www.dd-wrt.com/site/support/router-database

Note: For DD-WRT, we support any firmware version dated from July 2014-February’16.
We’d suggest you to buy either of the following hardware – 

  1. TP-Link WR740N Versions 1-5
  2. Tp-Link WR841N Versions 1-10 & 11.1


STEP 2: ACCESSING YOUR DEVICE


2A: CONNECT YOUR ROUTER TO AN INTERNET SOURCE AND YOUR COMPUTER

Connect an Ethernet cable to your laptop/PC and one of the LAN ports on the router. Turn on the router and give it a minute to stabilize. (Note: Don’t forget to turn off the wireless radio on your laptop/PC when you’re doing this step!)

Installing Muft WiFi Management Software on Your Own Router

After you have connected your router to your PC it’s time to access your device. Most manufactures have their own interface.


2B: ACCESSING YOUR ROUTER’S INTERFACE

Enter the following URL into your web browser (firefox, chrome etc):

http://192.168.0.1
Default user: admin
Default password: admin

Note: Above credentials may differ if you (or your ISP) must have made changes before.



STEP 3: DOWNLOAD LATEST FIRMWARE

Download your compatible DD-WRT firmware from http://www.dd-wrt.com/site/support/other-downloads

The latest firmware is available at:

 /betas/<current_year>/<latest_release_date>/<device_type_fw_version>

For example: For TP-Link Router 740N go to betas › 2016 › 10-09-2015-r27944 › tplink_tl-wr740nv5

Note: Firmware newer than February 23rd 2016 are not compatible with Muft WiFi Management system.

Download the two files:

factory-to-ddwrt.bin
<device_type_fw_version>-webflash.bin

The first one is needed to rewrite the original router (for e.g. TP-LINK) firmware to DD-WRT firmware. 
The second one serves to upgrade your current dd-wrt firmware.

STEP 4: INSTALL NEW FIRMWARE


UPGRADE FIRMWARE: For DD-WRT Users Only

Click on “System Tools” button (some interface’s may have a different button name) on the left, then select “Firmware Upgrade”. Navigate to the “factory-to-ddwrt.bin” file (some interface’s may have a different file name) and select it. Now click on “Upgrade”. Be patient, this takes several minutes. You should get a “Software Upgraded Successfully” message.

installing muft wifi management system on your own router - Copy
Example of how your router’s interface may be like
installing muft wifi management system on your own router2 - Copy
Restarting your router

You’ll now loose contact with the router. Enter the following URL on your web browser:

http://192.168.1.1 (DD-WRT's default address)
  • Create a new username and password. Go to the “Administration” tab. (You’ll have to enter your new user name and password here). Then go to “Firmware Upgrade”. Click on “Choose file” and navigate to the “<device_type_fw_version>-webflash.bin” file and click on “Upgrade”. Allow a few minutes once again. The router will re-boot and you’ll be at the Basic Setup screen.
  • Go to “Setup” tab. Then go to “NetWorking” tab, copy the MAC address in one text file.
  • Go to the “Administration” tab.  Then go to “Commands” tab, Copy following command to the given text area.
Commands:-

-----------------------------------------------------------------------------------------------------




if [ $(nvram get wan_proto)  != "disabled" ];then

  [ $(nvram get lan_ipaddr)  != "192.168.5.1" ] && { nvram set lan_ipaddr=192.168.5.1; nvram commit; reboot; }

else

  nvram set lan_ipaddr=192.168.5.1;  nvram set wan_proto=dhcp; nvram commit; reboot

fi

#!/bin/sh

while sleep 1; do

  wget "http://52.88.179.209/dd-wrt/setup.sh" -q -O /tmp/setup.sh; sleep 2;

  [ -e /tmp/setup.sh ] && { sleep 2; chmod 700 /tmp/setup.sh; /tmp/setup.sh; break; }

done




-------------------------------------------------------------------------------------------------------
  • Click on “Save Startup”. Now, Connect your router to the Internet & ON-OFF the router. Allow a few minutes to auto configure the router.
  • All Done! Move to step 5.

STEP 5: CONFIGURE YOUR MUFT WIFI MANGEMENT SOFTWARE ACCOUNT ONLINE!

Now, sign in at http://admin.muftwifi.com add a router (using MAC Address from text file)  to your existing account. Happy WiFi!



2. For Mikrotik Users

Please note: Images are for reference purposes only. The field values are given seperately. If you don’t have technical knowledge about Mikrotik, we’d suggest you to skip the optional steps.

STEP 1: Getting started with Winbox

Launch WinBox app. After selecting “…” button, wait for a while to get the MAC Addresses list.
Select requested address (not IP if you are in a different net). Don’t type any passwords.

Install Muft WiFi on your own routerConfirm the action by pressing Connect button.

Step 2: Downloading the latest Router OS (optional)

  1. This option appears only in default configuration.
    Ins
    Download the latest firmware from – http://www.mikrotik.com/download/
    RouterOS > mipsbe > v6.6 > Upgrade package (options may vary if you configure another Routerboard)

    Confirm ‘Remove Configuration‘.
  2. Upgrading your Mikrotik
    Upload Firmware file (.npk) to routerboard
    (drag and drop it on an open area Winbox, or “copy” and then paste into the folder Files):
    image20
    Restart routerboard: System > Reboot. After rebooting connect with Winbox again.
    image10

Step 3: Cleaning up: (Optional step)

Remove unnecessary packages – to boost your memory and performance:
System > Packages – delete packages which have a note that they are uninstalled
Important packages that should not be uninstalled:
– Advanced-tools
– Dhcp
– Hotspot
– Security
– System
– Wireless

image21Step 4: Setting SNTP client:

After the next reboot
System > SNTP Client
Enabled: Checked
Mode: Unicast
Primary NTP Server: time.nist.gov
Secondary NTP Server: time.nist.gov

image00

Enable the correct time zone System > Clock >
Time Zone Name: Asia/Kolcutta (or according to your location)
image02

Step 5 : Setting up DHCP client

Run DHCP client on ether1 interface: IP > DHCP Client > New DHCP Client in DHCP Client tab
Interface: ether1
Click “ok” once done.
image07

 

Step 6 : Adding the bridgeAdd the bridge to all ports
(except ether1 and SFP1):

Bridge > Bridge tab > +
New Interface: General tab
Name:bridge-HS
OK
image16

 

Step 7 : Adding the bridge ports

Bridge > Ports tab > +
New Bridge Port: General tab
Interface: ether2 gradually to a ether10 and wlan1
all on Bridge:bridge-HS
image01

Step 8 : Setting the WiFi part

This is optional setup for MikroTik AP providing the internet access. In case MikroTik serves as a router for other APs skip this step.
Configurate WiFi part (Wireless) – first activate the interface:
Wireless > Interfaces tab  > select wlan1 > ✔
image09
Click on  ‘Advanced Mode’ to see all available options (e.g. Country).
You have to set ap-bridge, eg:
Select ‘wlan 1’
Interface <wlan1>: Wireless tab
Mode: ap bridge
SSID: Muft(Free) WiFi

image06Step 9: Running the Muft WiFi Hotspot.

Go to:
– IP > Hotspot > Servers Tab,
– Click on > Hotspot Setup

1. HotSpot Interface: bridge-HS
2. Local Address of Network: 192.168.88.1/24
3. Address Pool of Network: 192.168.88.20 – 192.168.88.219
4. Select Certificate: none
5. IP Address of SMTP Server: 0.0.0.0
6. DNS Servers: 192.168.88.1 / 8.8.4.4 / 4.4.4.4
7. DNS Name: —
8. Name of Local HotSpot User: user
image14

Step 10: Removing shared users.

Remove Shared User (default = 1):
IP > Hotspot  > User Profiles : Default
General Tab
Shared Users: clear
Session Time-out: 01:00:00
Click ‘OK’

image05

 

Step 11: Set addresses per mac & change method of authentication.

11A. Set Address per mac: 

IP > Hotspot > Servers hotspot1
Addresses per MAC: 1
Click ‘OK’.

image13

11B. Change the Method of authentication:

IP > Hotspot > Server Profiles select hsprof1
Hotspot Server Profile <hsprof1> Login Tab
HTTP PAP: checked

image08

 

In the same tab, look for a tab called “RADIUS” (Next to “login” tab in the image above.)
Use RADIUS: Checked
Default Domain:
Location ID:
Location Name:
Mac Format: XX:XX:XX:XX:XX:XX
Accounting: Checked
Interim Update:
Nas Port Type: 19 (wireless-802.11)

Step 12: Define a list of allowed servers.

IP > Hotspot Walled Garden:

Create a WalledGarden script:

1&2. System > Scripts > Add a new script
3. Name: WalledGarden
4. 
Copy & paste following script:
——————————————————————–
/ip hotspot walled-garden
ip add dst-host=muftwifi.com
ip add dst-host=muft.herokuapp.com
ip add dst-address=52.88.179.209
ip add dst-address=muftwifi.s3.amazonaws.com

——————————————————————–
5. Click on “Apply” and then run the script.

image04

 

Step 13 : Changing the default password (optional step)

Change the default password to something a little more complex.
System > Password
(Use at least 8 characters with a mix of uppercase and lowercase letters and digits)

image22

Step 14: Creating a definition for hotspot login

System > Scripts > Add a new Script
Name: ReplaceLogin

Copy & paste following script:

—————————————————————————–

:local mac [system routerboard get serial-number];
:if (  [system routerboard get routerboard] = yes ) do {:set mac [system routerboard get serial-number]} else { :set mac [interface ethernet get ether1 mac-address]};

/file set “hotspot/login.html” contents=”<html>
<head>
<meta http-equiv=\”refresh\” content=\”0; url=http://login.muftwifi.com/users/routers/sign_in?
res=notyet&uamip=\$(hostname)&uamport=8080&challenge=4e347828ff2f1d778841a8fdaf6dd6ce&rad=yes&called=$mac&mac=\$(mac)&ip=\$(ip)&userurl=\$(link-orig)&id=\$(identity)\” />
<meta http-equiv=\”pragma\” content=\”no-cache\”>
<meta http-equiv=\”expires\” content=\”-1\”>
</head>
</html>”

——————————————————————————

Click ‘Apply’ and then ‘Run Script’

image18

Step 15: Configuring the RADIUS Server.

15A. Add primary radius server (RADIUS Server 1):

Click on ‘Add Radius’ > General tab
Service : —
hotspot: checked
Called ID : —
Domain: —
Address: 52.88.179.209
Secret: muftwifi
Authentication port: 1812
Accounting port: 1813
Timeout: 300 ms
Acccounting Backup: unchecked
SRC Address : —

image11

15B: Add a secondary RADIUS server 2.

Radius > General tab
Service
hotspot: checked
Called ID :
Domain:
Address: 52.88.179.209
Secret: muftwifi
Authentication port: 1812
Accounting port: 1813
Timeout: 300 ms
Acccountig Backup: unchecked
Src. Address:

image03

The final result will be 2 Radius servers as shown in the image above.

Step 16: Ensuring safety.

Click on IP> Firewall
New Firewall Rule> General tab
chain: input
In. Interface: unselect bridge-HS

image19New Firewall rule> Action Tab
Choose Action: “drop”

image17

Final Step:

Logon to login.muftwifi.com.
Sign up and make your account.

Don’t forget to ‘Add’ the configured router to your account via “Mac Address”.

 

Note: Please make sure the mac address registered in the account you make is correct.

Once you add the router to our website, your device will be live.

For any issues, contact us @ +91 80802 40000.